[22.4] gvmd: gmp - Failed to parse client XML: Command Unavailable

After packaging the new release for Exherbo Linux and updating our Greenbone installation to the new version I’m seeing the following entry in gvmd.log appearing multiple times:

md gmp: INFO:2022-07-20 15h34.09 CEST:6460: Failed to parse client XML: Command Unavailable

It’s marked as INFO and things appear to work just fine, however I still wonder what the unavailable command actually is and if it’s missing or what the actual problem could be. I tried reviewing the source but couldn’t spot it.

GVM versions

gsad: Greenbone Security Assistant 22.04
gvmd: Greenbone Vulnerability Manager 22.4 (Manager DB revision 250)
openvas-scanner: OpenVAS 22.4.0
gvm-libs: 22.4.0

Environment

Operating system: Linux
Kernel: 5.18.12
Installation method / source: Exherbo Linux packages (source-based)

@tgurr try to add more log level? or add debug logging to sourcecode?

Eero

Hi,
I had the same problem, I do not know which command it is referring to, but we noticed it only logs/happens during login of any account. So it might be worth looking at the logs and see if they line up with when you log in.

Hey @tgurr and @Kiwi thank you for reaching out.

We are aware of that message and you can safely ignore it for now. Nevertheless we will look into it and remove/fix the occurrence of this message.

1 Like