Ability to modify report format for Greenbone Community Edition (version 4.2.24)

solved

#1

Hi there, first time posting here on the Greenbone Community forum! I’ve recently installed and configured the Community Edition of Greenbone Security Manager via Hyper-V, and I’ve configured a task to run a custom vulnerability scan against a number of our targets within the corporate network. I noticed that the vulnerability names show up as OID but not the actual text. When I attempt to generate the results in report format, the OID shows up as the vulnerability name but not the name itself. If I try to search for the name “Firewall Enabled” for instance, it wouldn’t show up as a result but would have to instead search it by OID ‘1.3.6.1.4.1.25623.1.0.80059’.

Is there a reason why the OID shows up? I tried running the feed upgrade and then ‘journalctl -f’ in the command shell as suggested from a previous post, but I get an error message: “Error: received handshake message out of context”.


Vulnerability ID instead of name listed in the results
#2

This topic has been discussed recently in a few threads:


#3

I had to re-run the feed update and reboot the server. The names are now showing up in place of the OIDs. I guess I had to just wait after all! Thanks for the help.