Are plugins with deprecated script_id still working?

Hello community , please help with this question.

I still have in my plugins folder some old scripts where deprecated script_id is used. I noticed that old plugins 2008-2010 are not anymore in the community feed, also found several fresh 2015 plugins which got updated script_oid instead of script_id.

Question is if plugins that i have with script_id run when i do a scan (are they working) or why they were removed from community feed ?

P.S. in UI if i search for script_id ex. 53215 i can still see this plugin but full oid will be displayed 1.3.6.1.4.1.25623.1.0.53215, how come ?

Thank you !

As soon as you’re updating to a GVM version not supporting script_id anymore (which is GVM-10, see Removal of deprecated NASL functions in upcoming GVM-10) these scripts will stop to work.

1 Like