Connection to CheckMK

I still trying to connect my Check_MK with my Greenbone Server… I’ve installed the gvmd tools from the master branch on the Greenbone Server and connect from the CheckMK Server with this command to the Greenbone Server:

OMD[MeineSite]:~/etc$ ssh greenbone -T “/home/user/.local/bin/gvm-script --gmp-username SECUN --gmp-password SECPASSWD socket --socketpath /home/user/install/var/run/gvmd.sock /home/user/scripts/check-gmp.gmp --status -T ‘Full and Fast 223’ --last-report -F IP.IP.IP.IP”

Its return:
GMP OK: 0 vulnerabilities found - High: 0 Medium: 0 Low: 0
|High=0 Medium=0 Low=0

but when i put this command in a Rule on Check_MK its show me in the main overview “(null)”

but when i look in the Host Settings and there to the Services, the Custom Service show me:
OK Custom
GMP OK: 0 vulnerabilities found - High: 0 Medium: 0 Low: 0

i dont understand why its tell me in the main overview a warning (null).
Maybe someone knows whats the problem?

Kind regards,

GVM versions

gsa: 8.0.1
gvm: 8.0.1
openvas-scanner: 6.0.1
gvm-libs: 10.0.1
gvm-tools: 2.0.0.beta1

Environment Greenbone Server

**Operating system: Ubuntu Server 18.4
**Kernel: 4.15.0-58-generic
**Installation method / source: Github

I already saw that i should normaly put the check-gmp.gmp script in the libexec directory on the check_mk server, but cause i have to use my self ssh connection i run the check-gmp.gmp script on my greenbone server not on the check_mk server, and not on the greenbone server neither than on the check_mk server i have a libexec directory…

I dont understand how i can make this variable enough to use it on a big network… In this setup like i do it i cant use the $HOSTADRESS$ parameter… and i also dont know how i can do the Task variable… I saw in a Docu that they replace the Task with $ARG1$… but i think this is an argument from the config file…so its dont take automaticly different tasks… So my question is now… How i can make it w.o making for every task an own rule?

and for my first topic i also dont have an idea why this is so…

Some help?