Database wrong version and psql error

GVM versions

gvmd: (‘gvmd --20.08’)
*gvm-libs: 20.08

Environment

**Operating system:DEBIAN 10
Kernel: (Linux OpenVas 4.19.0-10-amd64 #1 SMP Debian 4.19.132-1 (2020-07-24) x86_64 GNU/Linux
)
**Installation method / source:git

Hello, i migrated Openvas to the 20.08 version from the source code and i have a little problem.

after run my service gvmd i had an error.
In gvmd.log i found this error : gvmd: database is wrong version

So, i did that : gvmd --migrate (with gvm user) and i have this returns:

sql_exec_internal: PQexec failed: ERREUR: n’a pas pu charger la bibliothèque « /opt/gvm/lib/libgvm-pg-server.so » : libgvm_base.so.21: Ne peut ouvrir le fichier d’objet partagé: Aucun fichier ou dossier de ce type

In my folder /opt/gvm/lib :

lrwxrwxrwx 1 gvm gvm 22 janv. 28 10:49 libgvm-pg-server.so -> libgvm-pg-server.so.21
lrwxrwxrwx 1 gvm gvm 52 janv. 28 10:49 libgvm-pg-server.so.21 -> libgvm-pg-server.so.21.4.0~dev1~git-2b98743e9-master
-rw-r–r-- 1 gvm gvm 97872 janv. 28 10:49 libgvm-pg-server.so.21.4.0~dev1~git-2b98743e9-master

So i don’t understand why it doesn’t work :confused:.

Can you help me ?

if i understand this correctly you are using the master version. thats for developing. use branch 20.8.