Discourse false positives

Currently lots of Discourse tests return false positives because the version comparion is not working since Discourse has 2 digit beta version numbers.

Discourse is currently at 2.8.0.beta11 and the tests think that beta11 is older than beta8 etc. The following tests return false positives:

  • 1.3.6.1.4.1.25623.1.0.117756 (fixed in 2.8.0.beta7)
  • 1.3.6.1.4.1.25623.1.0.146524 (fixed in 2.8.0.beta5)
  • 1.3.6.1.4.1.25623.1.0.117702 (not fixed?)
  • 1.3.6.1.4.1.25623.1.0.117566 (fixed in 2.8.0.beta3)
  • 1.3.6.1.4.1.25623.1.0.147245 (fixed in 2.8.0.beta9)
  • 1.3.6.1.4.1.25623.1.0.147184 (fixed in 2.8.0.beta8)
  • 1.3.6.1.4.1.25623.1.0.146397 (fixed in 2.8.0.beta4)

It seems that this is already fixed and only my feed update cron job was broken.

Hi @sven1 and welcome to the forum :slight_smile:

I’m glad it’s working and thanks for letting us know.

4 posts were split to a new topic: False positive, two digit version number