Emailed PDF report different from exported PDF report

gvm-9

#1

Hi all

First post, so be gentle :slight_smile: :slight_smile: :slight_smile:

I’ve discovered this weird thing, which I hope, someone can help me with.
I run a ScanTask.
This ScanTask has an alert conifigured, which sends me an email with the report attached as PDF.
The scan completes, and the email gets send.
However the attached PDF file containes more information than the information, I asked for.
in ex. it includes “log” and “false positive” results, and also writes “Issues with the threat level ‘High’ are not shown” and so on. Since all threat levels are shown in the report, something is wrong… :frowning:
Then I go to the report list, and download the report from the same ScanTask as PDF manually - THIS report is OK.

Some information on my running system:

OS: Kali Linux (“4.18.0-kali2-amd64”)
GSA: version 7.0.3
OpenVAS Scanner: 5.1.3

ANY help is greatly appreciated

PS: I also tried to make an email alert, which sends a Latex-file - this is also faulty!


#2

The applied filter in the alert may not be the same as when displaying the report results. Therefore you should create a result filter and use it in the alert for consistent email reports.


#3

@bricks: Thanks for Your reply :slight_smile:
Can You give me a link to a guide of how to make these “result filters”?
I cannot seem to find anywhere to read about the syntax etc?

Thank You again :slight_smile:


#4

Please take a look at the Alerts section in the manual for setting a Report Result Filter

https://docs.greenbone.net/GSM-Manual/gos-4/en/vulnerabilitymanagement.html#alerts


#5

@bricks: This seems to be the way - THANKS! :smiley:
I will now go into “seek-and-You-shall-find mode” to see, what I can type into the filter line :smiley:
For now, I’ve got, what I wanted by typing:
severity>log apply_overrides=1 min_qod=70 first=1 rows=1000 sort=name
into a Result Filter, and aplying that to my alert.

Thanks again!


#6

Don’t know if this works. Normally severity expects a number like severity > 5.0 or something. The severity levels can be adjusted by using the levels filter parameter like levels=hmlgf (include high, medium, low, log, false positives) or levels=hml (include only high, medium and low)


#7

I rest my case - it works perfectly!

I have no further questions :slight_smile: