Greenbone-nvt-sync (Rsync error)

GVM versions

gsa: 9.0
gvm: 9.0
openvas-scanner: 7.0
gvm-libs: 11.0

Environment

Operating system: Raspbian (Buster)
Kernel: 4.19.98-1+deb10u1
Installation method / source: GVM11 - Source branch

Hi everyone,
I installed everything from sources. When I try to update nvt (with greenbone-nvt-sync), I get an error which say that many files weren’t transfered (error code 23). However, when nvt sync is processing, I don’t see any issue. When I try to run again greenbone-nvt-sync, nothing appears. I looked into log file but I only see that “Rsync failed” and nothing else.

Systemctl tells me that rsync service is inactive. The issue is due to there is no /etc/rsyncd.conf file by default. I see a lot of different topics on installing GVM but anyone talks about rsync configuration.


Is there a default configuration file installed with sources or does someone has an idea on how to solve that?

What do you want to do by running a rsync server ?

There is no rsync configuration file needed. The greenbone-nvt-sync script is a standalone, rsync client script, which will update your NVT feeds. That’s it.

The problem you’re facing might just be:

  1. Greenbone RSYNC server may just be full. In that case, try again later.
  2. You have a firewall / Network accelerator / broken proxy in the middle which breaks the rsync transfer

From my experience doing the NVT feed synchronization via RYSNC often fails. You may need to retry several times until it actually works. Another option is to use the --wget flag; which force the script to use HTTP instead of RSYNC. It works much better but is unfortunately overkill from a network bandwidth perspective and slower.

1 Like

This wont work with the latest releases and after 1st of July anymore.

2 Likes

Well, hopefully the new community rsync feed will work. The old community feeds often times out.