GSM Trial Failing on Size vs prev_size in fastbins

GVM versions

GSM Trial v21.04.1 on Oracle VirtualBox

Environment

Operating system:
Kernel: (‘uname -a’) Linux gsm 4.19.0-16-amd65 #1 SMP Debian 4.19.181-1 (2021-03-19) x86_64 GNU/Linux
Installation method / source: GSM Trial on Oracle VirtualBox

The scanner task is no longer working and I keep getting this error:
gsm ospd-openvas[495]: corrupted size vs prev_size in fastbins
gsm sudo[7153]: pam_unix(sudo:session): session closed for user root
gsm pspd-openvas[6503]: OSPD[495] ERROR: (ospd_openvas.daemon) Task f82…00db was unexpectedly stopped or killed

I installed version 21.04.1 in May, I ran the first 3 scans and it worked okay, and then after that none of the scans I have tried have worked. The “journalctl -f” shows me that error after about 15 minutes of execution. When it was working, it took about 8 hours to run normally.

I have rebooted the PC and get the same result.

Any ideas on what I should do to fix this?

Hey, thank you for reporting this! It is probably a bug on our side.

We have released the GSM TRIAL 21.04.2 in the meantime. Since we only use the newest version as a base for bugfixes, can you please check if the problem occurs there? ⟶ https://www.greenbone.net/en/testnow/#downloadnow

If the problem persists, I can forward this issue to our developers. However bugs of this kind are very hard to reproduce, and we will need more information:

  • Which scan config and port list did you use?
  • Were any credentials configured for the task?
  • Which alive test was configured for the target?
  • How many hosts and excluded hosts did the target have?
  • What kind of hosts and excluded hosts were configured? IPv4, IPv6, hostnames, or mixed?
  • At your discretion: What were the actual targets? E.g. which operating systems? Do they have virtual hosts (vhosts)? Were there firewalls or intrusion detection systems between the GSM TRIAL and the target?

Feel free to send me a private message if you do not want to disclose any information publicly, and thank you for any information you can provide!

1 Like

How do you send private messages on the community portal?

Click my username and a popup with a “Message” button should appear.

I don’t seem to have access to that. When I click your username I just see topics and your name.

Information was provided via private message. We will try to reproduce the problem. If we can reproduce it, we will fix it.

2 Likes