Have a lot of <name>EXIT_CODE</name>\r\n <value>EXIT_NOTVULN</value>

Hi have an issue with the xml report both anonymous and not, from the web interface and from the python gvm. When download the report i have a lot of tag EXIT_CODEEXIT_NOTVULN
example<name>EXIT_CODE</name><value>EXIT_NOTVULN</value><source> <type>nvt</type><name>1.3.6.1.4.1.25623.1.0.804874</name><description></description></source><extra></extra></detail><detail> <name>EXIT_CODE</name><value>EXIT_NOTVULN</value><source> <type>nvt</type><name>1.3.6.1.4.1.25623.1.0.103034</name><description></description></source><extra></extra></detail><detail>

how it’s possible to export the report without this value? I try a lot of filters but without success.
ps in csv or text or pdf report with the same filters i not show these values.

thanks in advance

GVM versions

**gsad:Greenbone Security Assistant 9.0.1 (‘gsad --version’)
**gvmd:Greenbone Vulnerability Manager 9.0.1 Manager DB revision 221 (‘gvmd --version’)
**openvas-scanner:OpenVAS 7.0.1 (‘openvas --version’, in older GVM versions < 11: ‘openvassd --version’)
**gvm-libs:gvm-libs 11.0.1

Environment

**Operating system:ubuntu 20.04
**Kernel:Linux c43f270261ac 5.4.0-42-generic #46-Ubuntu SMP Fri Jul 10 00:24:02 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux (‘uname -a’)
**Installation method / source:docker

If I remember correctly these host details are used for the AutoFP feature.

There is currently no filter parameter to remove these host details from the XML export.

1 Like

ok, but from the gvm script or python gvm it’s possible to get the report like the xml export from the web interface?. Because i try to export the same report with the same filters but te result are different. The report from gvm script or python gvm start with different data

What’s the difference between both reports?

at the start of the exported report the xml start with <get_reports_response status=“200” status_text=“OK”>but i resolved re editing the xml with only the data that i need. deleting al the AutoFp etc etc

Many thanks!