Max row per page

Hi all,
I need to change max row per page parameter but when I run
gvmd --modify-setting myuuid --value 1500 I get error “Error in setting UUID”.
I don’t know which uuid I have to give so I tried with scanner-uuid, report id and task id without successfull.
Can anyone helpme?
Roberto

Environment:
Greenbone Security Assistant 8.0.0
Greenbone Vulnerability Manager 8.0.0
Manager DB revision 205
OpenVAS Scanner 6.0.0
gvm-libs-devel-10.0.0-6924.el7.art.x86_64
gvm-libs-10.0.0-6924.el7.art.x86_64
centos7 3.10.0-957.21.3.el7.x86_64

Hi roberto,

in order to modify a setting, you need to send the uuid of the setting you want to modify.

https://docs.greenbone.net/API/GMP/gmp-8.0.html#command_modify_setting

As a note, though, “max rows per page” is immutable and you can not increase that number. You can increase “rows per page”, but this has an upper limit of “max rows per page” (1000).

Hi Steffen, thank you for your answer. Is there a way to get my uuid setting from command line?
My problem is about a report with more than 1500 item of medium severity. When I try to export the report in any format I am not able to get all the items. Can I do anything to get all them?
Thank’s
Roberto

For downloading the reports you can set rows=-1 in the filter which you are sending with the command.

Hi Steffen, thank’s for your answer. It doesn’t work. When I put rows=-1 it’s immediately convert in rows=1000 and the report output don’t shows the other items that are about 1500.
Roberto

You could try to set ignore_pagination=1 in the filter for getting a report.

1 Like

Btw. max rows per page is an immutable setting and can’t be increased.

1 Like

Thanks for your answer Bricks. Doesn’t work ignore_pagination=“1” either.
I understand that I can’t do grow “max rows per page” but I think that there must be a way to have the complete report if you want.
Moreover “max rows per page” make me thinks at number of row in a single page not max item per report (I don’t speak English and I’m using google traslate for this post so It’s possible that I don’t understand the right meaning of the words).
Howover it’s not a realy problem but just a nuisance.
Thank’s
Roberto

To get the full list of results of a single report you have to use ignore_pagination=1 levels=hmlg min_qod=0 as the filter. Otherwise the max rows per page limit will be applied. The max rows per page setting is immutable.

1 Like