Missing Superuser Option

Hi,

I recently upgraded the Greenbone Community Edition version 4.2.24 to version 4.3.14. After setting all up, I realised, that there is no Superuser option in the Advanced>Support Menu.

Now I have two questions:

  1. Is this intended?
  2. Is there an other way to gain root access for the shell?

Thanks,
Jan

Okay, I will answer my question by myself. It is possible to still use the old Greenbone 3 command line inferface with gos-state-manager instead of gsm. This in mind it is easily possible to still activate the superuser/root for the shell.

How do you do this?

How can I use the super user in shell?

Thanks

Hi,
sorry for the late reply.
Just in case you haven’t figured it out yet, you have to open the Shell via the Support Menu.
In the shell you have to enter the following commands:

  1. gos-state-manager set superuser enabled
  2. gos-state-manager set superuserpassword password
  3. gos-state-manager save

To 1: This command enables the superuser account.
To 2: This command is used to set the superuser’s password, where password needs to be replaced with your favourite password. :wink:
To 3: You need to save the configuration with this command.

Jan

Hi,

just some notes. Getting super user isn’t supported and should not be done under normal circumstances.

Using gos-state-manager directly is highly discouraged. DOING SO MAY BREAK YOUR SYSTEM.

1 Like