No NVTs available

Hi,

I am trying to sync nvt data with command: greenbone-nvt-sync --rsync and after some minutes, it completed without any error.

And from the Feed status, it shows this as well:

However, when i go to tab SecInfo, then it does not show anything: No NVTs data.

But for other datas, they are available like CVEs:

Thank you so much for your help!

Viet

Hi @vietnguyen,

On SecInfo check if CVE, CPEs and others are available or not, is none of them are available, probably the SCAP data base is missing, follow this link to solve it SCAP Issues. Is very important to ready the description and follow the step-by-step instructions to solve the issue.

Best

1 Like

Hi @Itcracker Thank you for your reply. It is just NVT data unavailable only. Other datas are available.

Do you have any idea?

Hi,

is a similar issue here:

try to find what could be the root cause in your environment.

1 Like

Hi @vietnguyen,

It is clear that the installation is not complete reason why it is missing NVTs.
I suggest you to re-run the command sudo gvm-setup to see if it fix the issue.
Note: After the process is done, login to GSA and got to Feed status and if you see: updating in process, wait until the process if finished and go to NVTs to see if the problem persists or not.

Best

1 Like

Same symptoms as reported for GVM 2.1 on Ubuntu 20.04LTS. GVM was working yesterday, but not today. Server and processed have been rebooted, and the symptoms are:

  • Administration:Feed Status:NVTs: reports “No NVT’s available”
  • running terminal operation of “greenbone-nvt-sync --rsync” shows data being loaded
  • Administration:Feed Status: has “Update in progress…” for all feed types

I will wait a day to see if the “Update in progress…” changes, but I don’t have high hopes.