NVT timed out after 320 seconds

Getting Error “NVT timed out after 320 seconds” when scanning machines. In advice would be helpful. based on the search here it seems to be fixed by upgrade but it was for the an older version of vas 9 & 11 but I’m running 20.08 which would not make a difference.

GVM versions

**gsad:20.08.1~git-10e848847-gsa-20.08
**gvmd:20.08.1~git-10e848847-gsa-20.08
**openvas-scanner:20.8.2
**gvm-libs:20.8.2~git-9640de4-gvm-libs-20.08

Environment

**Operating system: Ubuntu
**Kernel:5.4.0-72-generic
**Installation method / source: Source

There is no / was never a fix for this message required (maybe what you have read was that the NVT name causing the message wasn’t visible, that got indeed fixed in the past).

The message itself is only telling you that the VT in question didn’t get a response / slow responses in the default timeout of 320 seconds and was terminated by the scanner.

You have a few options to avoid this message:

  1. Check why the service in question is slowly / not responding
  2. Assign more resources (e.g. CPU, RAM, …) to the service in question
  3. Whitelist the scanner in any security equipment (e.g. Firewall, IDS/IPS, WAF, …) so that these are not interfering with the scan (e.g. these could cause longer running tests, timeouts etc.)
  4. Raise the default plugins_timeout in the scan config to a higher timeout to give the VT in question more time to complete
1 Like