openVAS login issue "An error occurred during making the request. Most likely the web server does not respond."

Hi,

I have tried to login to openVAS on my Kali Linux version 2021.1 however it shows some error as shown below. Any suggestion how to resolve the issue I am new to here.

Here are the version I am working on:
┌──(kali㉿kali)-[~]
└─$ gsad --version
Oops, secure memory pool already initialized
Greenbone Security Assistant 20.08.1~git

┌──(kali㉿kali)-[~]
└─$ gvmd --version
Greenbone Vulnerability Manager 20.08.1
Manager DB revision 233
Copyright © 2009-2021 Greenbone Networks GmbH
License: AGPL-3.0-or-later
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

┌──(kali㉿kali)-[~]
└─$ openvas --version
OpenVAS 20.8.1
gvm-libs 20.8.1
Most new code since 2005: © 2021 Greenbone Networks GmbH
Nessus origin: © 2004 Renaud Deraison deraison@nessus.org
License GPLv2: GNU GPL version 2
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

┌──(kali㉿kali)-[~]
└─$ lsb_release -a
No LSB modules are available.
Distributor ID: Kali
Description: Kali GNU/Linux Rolling
Release: 2021.1
Codename: kali-rolling

Try running

`sudo gvm-check-setup`

it tells you the error. Most likely it’s an invalid certificate, but it should give you a specific fix.
If it is an invalid certificate, you can fix it by running
sudo runuser -u _gvm -- gvm-manage-certs -a -f

1 Like

You also should check the gsad.log file somewhere in /var/log for errors.

3 Likes