Plugin_add: Assertion category >= ACT_INIT && category <= ACT_END' failed

Hi ,

I am also facing the issue but it is not because the host is not resolvable, I have run a scan for the same before and got the report too.

Below is the error I am getting

event target:MESSAGE:2020-05-27 16h03.46 UTC:3103: Target main_server (0e42df8c-b215-450a-a2a9-fe5ba7f9bcb9) has been created by admin
event task:MESSAGE:2020-05-27 16h04.02 UTC:3155: Status of task (6d0219d0-c390-450e-9b37-9aeef666ea4b) has changed to New
event task:MESSAGE:2020-05-27 16h04.02 UTC:3155: Task Test (6d0219d0-c390-450e-9b37-9aeef666ea4b) has been created by admin
event task:MESSAGE:2020-05-27 16h04.33 UTC:3258: Status of task Test (6d0219d0-c390-450e-9b37-9aeef666ea4b) has changed to Requested
event task:MESSAGE:2020-05-27 16h04.33 UTC:3258: Task Test (6d0219d0-c390-450e-9b37-9aeef666ea4b) has been requested to start by admin
event task:MESSAGE:2020-05-27 16h04.44 UTC:3268: Status of task Test (6d0219d0-c390-450e-9b37-9aeef666ea4b) has changed to Running
md main:WARNING:2020-05-27 16h04.45 UTC:3268: openvas_scanner_read: Failed to read from scanner: Connection reset by peer
event task:MESSAGE:2020-05-27 16h04.45 UTC:3268: Status of task Test (6d0219d0-c390-450e-9b37-9aeef666ea4b) has changed to Interrupted

Also, I did the nvt, scap and cert update some time back and after that, I am getting this issue

It is interrupting the task every time I m trying to run any scan.
Please help me in resolving the issue.

Version details
gvm-tools==2.1.0
gsad --version
Greenbone Security Assistant 8.0.0
gvmd --version
Greenbone Vulnerability Manager 8.0.0
openvassd --version
OpenVAS Scanner 6.0.0
openvas-nasl --version --debug-tls=1
openvas-nasl 10.0.0
gnutls 3.3.29
libssh 0.7.1/openssl/zlib
gpgme 1.12.0

also i see this error at openvas-scanner service logs

[root@test-openvas log]# service openvas-scanner status -l
Redirecting to /bin/systemctl status -l openvas-scanner.service
● openvas-scanner.service - OpenVAS Scanner
Loaded: loaded (/usr/lib/systemd/system/openvas-scanner.service; enabled; vendor preset: disabled)
Active: active (running) since Wed 2020-05-27 10:32:50 EDT; 1h 50min ago
Process: 25391 ExecStart=/usr/sbin/openvassd $SCANNER_SOCKET $SCANNER_MODE $SCANNER_GROUP $SCANNER_OWNER (code=exited, status=0/SUCCESS)
Main PID: 25392 (openvassd)
CGroup: /system.slice/openvas-scanner.service
├─ 5115 openvassd: Serving /var/run/openvassd.soc
└─25392 openvassd: Waiting for incoming connection

May 27 10:32:50 test-openvas systemd[1]: Starting OpenVAS Scanner…
May 27 10:32:50 test-openvas systemd[1]: Started OpenVAS Scanner.
May 27 10:51:23 test-openvas openvassd[25391]: openvassd: /builddir/build/BUILD/openvas-scanner-6.0.0/src/pluginscheduler.c:87: plugin_add: Assertion category >= ACT_INIT && category <= ACT_END' failed. May 27 11:06:54 test-openvas openvassd[25391]: openvassd: /builddir/build/BUILD/openvas-scanner-6.0.0/src/pluginscheduler.c:87: plugin_add: Assertion category >= ACT_INIT && category <= ACT_END’ failed.
May 27 11:30:12 test-openvas openvassd[25391]: openvassd: /builddir/build/BUILD/openvas-scanner-6.0.0/src/pluginscheduler.c:87: plugin_add: Assertion `category >= ACT_INIT && category <= ACT_END’ failed.

Is this have anything to do with the above issue?

Hi,
Can i have any update on this ?

Please don’t bump a topic within such a short amount of time. Please also note that in this forum all questions are answered on voluntary basis. If you need support with a SLA please take a look at our products.

Btw. updating to the latest bugfix releases may help.

2 Likes