Problem occured in scanning because a mandatory key is missing


#1

hey there,

I want to know which packages in my host are vulnerable, so I used the Full and very deep scan config but it doesn’t work for me. After checking the openvassd.messages file, I figure out there is a problem in gather-package-list.nasl plugin running. what’s the main reason of this problem?

[Mon Jan 28 11:05:39 2019][5683] Not launching gather-package-list.nasl (1.3.6.1.4.1.25623.1.0.50282) against 192.168.0.14 because a mandatory key is missing (this is not an error)


#2

Looks like your authentication didn’t work. Have a look at https://community.greenbone.net/t/hint-verify-target-configuration-access-for-authenticated-lsc-scans/219 about requirements and indications for a successful authentication.

That said I would recommend to start with a “Full and fast” scan. This config will do authenticated checks as well (provided that your authentication is set up correctly). The difference between these scan configs is rather e.g. how unscanned ports are treated than if authentication is enabled or not.