Rsync: [generator] failed to set permission

Hi! i get this error message on runuser -u _gvm -- greenbone-nvt-sync as root and sudo too

rsync: [receiver] failed to set permissions on "/var/lib/openvas/plugins/2021/suse/.gb_sles_2018_2976_1.nasl.bskdHi": Function not implemented (38)
2021/suse/gb_sles_2018_2977_1.nasl
          6,967 100%    9.92kB/s    0:00:00 (xfr#70239, ir-chk=4224/75373)
rsync: [receiver] failed to set permissions on "/var/lib/openvas/plugins/2021/suse/.gb_sles_2018_2977_1.nasl.dLDTHf": Function not implemented (38)
2021/suse/gb_sles_2018_2978_1.nasl
          4,803 100%    6.37kB/s    0:00:00 (xfr#70240, ir-chk=4223/75373)
rsync: [receiver] failed to set permissions on "/var/lib/openvas/plugins/2021/suse/.gb_sles_2018_2978_1.nasl.k3gpIg": Function not implemented (38)
2021/suse/gb_sles_2018_2979_1.nasl
          4,589 100%    5.85kB/s    0:00:00 (xfr#70241, ir-chk=4222/75373)
rsync: [receiver] failed to set permissions on "/var/lib/openvas/plugins/2021/suse/.gb_sles_2018_2979_1.nasl.jIpWmj": Function not implemented (38)
2021/suse/gb_sles_2018_2980_1.nasl                                  

rsync: [generator] failed to set permissions on "/var/lib/openvas/plugins/.": Function     not implemented (38)
rsync: [generator] failed to set permissions on "/var/lib/openvas/plugins/404.inc": Function not implemented (38)
rsync: [generator] failed to set permissions on "/var/lib/openvas/plugins/AfterLogic_WebMail_Pro_detect.nasl": Function not implemented (38)

rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1819) [generator=3.2.3]

GVM versions
Greenbone Security Assistant 21.4.2
Greenbone Vulnerability Manager 21.4.3
OpenVAS 21.4.2
gvm-libs 21.4.2

Environment
Kali linux
Linux kali 5.10.0-kali9-amd64 #1 SMP Debian 5.10.46-4kali1 (2021-08-09)
Installed from kali repository

It seems your filesystem settings are not correct, you need a system with full UNIX permissions. That might occur if you are not controlling the underlying permission systems (NFS/ CFIS) or your filesystem like FAT does not support permissions or you limit the user-process by the kernel to set it, even as root.

thanks for reply.my filesystem is ext4, what operations can I do to check that everything is in order?about NFS/CFIS

Check if SE Linux is enabled and disable it, or write a policy and publish it.

Se linux is not installed

Then you need to strace it and check why the permission could not be set.

I don’t follow you, how?

I am running into this same issue.
gvm-check-setup 1 ⨯
gvm-check-setup 21.4.2
Test completeness and readiness of GVM-21.4.2
Step 1: Checking OpenVAS (Scanner)…
OK: OpenVAS Scanner is present in version 21.4.2.
OK: Server CA Certificate is present as /var/lib/gvm/CA/servercert.pem.
Checking permissions of /var/lib/openvas/gnupg/*
OK: _gvm owns all files in /var/lib/openvas/gnupg
OK: redis-server is present.
OK: scanner (db_address setting) is configured properly using the redis-server socket: /var/run/redis-openvas/redis-server.sock
OK: redis-server is running and listening on socket: /var/run/redis-openvas/redis-server.sock.
OK: redis-server configuration is OK and redis-server is running.
OK: _gvm owns all files in /var/lib/openvas/plugins
OK: NVT collection in /var/lib/openvas/plugins contains 21270 NVTs.
Checking that the obsolete redis database has been removed
OK: No old Redis DB
OK: ospd-OpenVAS is present in version 21.4.2.
Step 2: Checking GVMD Manager …
OK: GVM Manager (gvmd) is present in version 21.4.3.
Step 3: Checking Certificates …
OK: GVM client certificate is valid and present as /var/lib/gvm/CA/clientcert.pem.
OK: Your GVM certificate infrastructure passed validation.
Step 4: Checking data …
ERROR: SCAP DATA are missing.
FIX: Run the SCAP synchronization script greenbone-feed-sync.
sudo runuser -u _gvm – greenbone-feed-sync --type SCAP.

ERROR: Your GVM-21.4.2 installation is not yet complete!

Please follow the instructions marked with FIX above and run this
script again.

This is what my gvm-check-setup looks like

I have been reading and seeing that it might be something to do with the environment or the network but from what this error is it is saying that it’s dealing with permissions. I have no clue what to do

sudo runuser -u _gvm – greenbone-feed-sync --type SCAP 1 ⨯

All transactions are logged.

If you have any questions, please use the Greenbone community portal.
See https://community.greenbone.net for details.

By using this service you agree to our terms and conditions.

Only one sync per time, otherwise the source ip will be temporarily blocked.

receiving incremental file list
timestamp
13 100% 12.70kB/s 0:00:00 (xfr#1, to-chk=0/1)
rsync: [receiver] failed to set permissions on “/tmp/tmp.17MHmEVcC9/.timestamp.dsTHV1”: Function not implemented (38)

sent 43 bytes received 115 bytes 35.11 bytes/sec
total size is 13 speedup is 0.08
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1819) [generator=3.2.3]

I removed part of the actual reply code that stated the community feed because it only allows to post two links and I could not figure out how to remove them without just deleting the text.

This was the attempt of following the fix after running the gvm-check-setup

hi AndyJAck, in which system does gvm run? kali linux?

what’s happens if u type gvmd --get-users --verbose ?

I solved doing chmod a+w -R /var/lib/openvas/plugins

1 Like

Facing similar issue…

Even tried chmod a+w -R /var/lib/openvas/plugins

chmod a+w -R /var/lib/openvas/plugins this is very very dangerous! Every user can change the nasl files now. These files are scripts executed with root(!) permissions. DON’T DO THIS!

I suppose you did break your setup by running some stuff as root user and not as the dedicated user (_gvm on Kali Linux).

1 Like

Looks like broken during update. I just ran distro-upgrade on Kali (where OpenVAS is running). And now it is working fine.