Scan not using openvas-smb tools during scan


#1

new install of greenbone vulnerability manager on centos 7. firewall disabled on host and greenbone machine. selinux disabled. able to authenticate via smb credentials using a network admin account, however in the Windows SMB/LSC Authenticated Scan Info consolidation we see the following 3 lines:

Access to the registry possible (SMB/registry_access) : FALSE
Extended SMB support available via openvas-smb module (Tools/Present/smb) : FALSE
Extended WMI support available via openvas-smb module (Tools/Present/wmi) : FALSE

This is regardless of whether or not we enable ‘Start Remote Registry Service’ - as this option appears to do nothing. We previously had OpenVas 9 installed and did not have this issue. We also noticed that if the remote registry service does not start we receive no vulnerability information. We can manually start the service on the target machine and get results. Is there a step during install to enable the openvas-smb tool or a scan setting? Please help. We have had issues using OpenVas/GVM since the update to 10


#2

A very similar topic was thoroughly discussed in https://community.greenbone.net/t/how-to-verify-openvas-smb-is-running/1580:

When getting the Tools/Present/smb output set to FALSE this means your environment is not correctly build / linked against the optional openvas-smb library and thus the supporting function are missing. There are currently two options go get this support back:

  1. If this is an installation build from source make sure that you have build openvas-smb before other components like gvm-libs, openvas-scanner etc.

  2. If this is an installation provided by a 3rdparty package repository make sure that openvas-smb is installed. If this package is not available please contact the maintainer of this repository to ask for building and packaging the openvas-smb library.


#3

I had previously looked through that article. We used atomicorp as our repo and openvas-smb-1.0.5-6923.el7.art.x86_64 is packaged. I am new to installing Greenbone so this has been a bit of a challenge for me, but one I have been attempting to work through. It seems the next best thing is to work through installing the Source Edition


#4

As an alternative you could also open a new issue at https://github.com/Atomicorp/openvas/issues/ to make the package maintainer aware of possible issues with linking the scanner to openvas-smb.