Scans only succeed with IP address targets, not with hostname targets

I have entered the IPs of my local DNS servers in the configuration but the server cannot resolve local hostnames. However, the server is able to resolve www.google.com and I have successfully downloaded the community feeds.
Scan tasks configured with specific local IP addresses succeed but tasks configured with the host name(s) of systems on the local network fail.
image
Even from the console, I see a “temporary failure in name resolution” error when trying to ping a local hostname but trying to ping a local IP address succeeds

Any ideas why local DNS is not working and how to fix this?
I am running the current Greenbone Enterprise Trial: OS 21.04.19

Hi! Welcome to our forum!

Regarding your local DNS settings it seems to be an issue with the resolving on your side. It seems that your router/modem is not resolving local domain names for whatever reason. I have found some further explanations or maybe solutions here and here. Have you set up your DHCP correctly?

1 Like

I am using a static IP address and I have entered three local DNS server IP addresses in the server configuration.
image

Your domain and/or domain search order needs to be set. I use the community version, and I have set the domain search order during the OS install.

If you can access a shell (ssh) to your server try to ping one of your servers by name. If that does not work, try server.domain. If that works, you need to set the domain search order.

1 Like