SecInfo Database Missing [RESOLVED]


#1

Hi, noob with some Linux experience here.

I have configured a Hyper-v VM install of the appliance download and can log into the web interface. The machine is on my local subnet with internet access. The machine has been running for several hours, yet I’m still seeing the below error in the browser interface.

Warning: SecInfo Database Missing

SCAP and/or CERT database missing on OMP server.

This is a home network with no outbound firewall restrictions.

There are some forum posts suggesting the command to manually run this database download is available however I couldn’t log in via SSH: “Network error: Connection refused”. After a couple of reboots this remedied itself and I can now SSH, but get the same green screen Greenbone OS Configuration screen as on the VM console. How do I drop into CLI please?

Please help? Am I heading in the right direction or have I misunderstood how the system works?


#2

Hi,

did you try to follow the steps below (from the GCE installation instructions) on how to sync the feeds?

A full and successful sync of the feeds is required to get the SecInfo Database filled. As long as no full sync was happening (there might be various reasons for this) you will get the mentioned “SecInfo Database Missing” message.

Download Feed: Without a feed you can not do any scans and the SecInfo section remains empty. So the download is highly recommended, but requires internet access.

The feed update now runs in the background and you are on the main menu of the administration. Via “About” you can have a look at the key properties of your setup, especially the address of the web interface and whether there still runs the Feed update as a system operation.

Only after the feed update completed there will be all information in the SecInfo area and first scans possible. This could take half an hour or even longer.


#3

Hi @cfi, yes I read that document. From the main menu in the Greenbone OS Administration page I went to Setup > Feed > and tried the Synchronisation option on “Switch automatic synchronisation to enabled” and also to ‘Disabled’ waiting several hours in between for a sync to happen.

About: No subscription key (using the community edition), feed version: Fri Oct 5 2018, GOS: 4.2.20.

Is there a way to force a download? How do I drop into the CLI from the green Admin page?

If I can’t get this to work I will try installing manually on top of Ubuntu or something.


#4

What is the live-log saying ? If you force a sync …

Maintenance -> Feed -> Upgrade

And then go to Support -> Shell: journalctl -f

You should be able to see the rsync and debug from there. Please not the GCF uses RSYNC native protocol, you need to allow this if you have any firewall or outbound restrictions in place.


#5

As a reference the related online documentation on this topic which should be valid for most parts of GCE as well:

https://docs.greenbone.net/GSM-Manual/gos-4/en/systemadministration.html#feed-management


#6

@cfi, @Lukas, thank you both, that was the direction I needed.

Maintenance -> Feed -> Upgrade
I had somehow not found that option after spending ages looking through the options.

And then go to:
Advanced ->Support -> Shell: journalctl -f
This was a great help!

It took several long hours on a fast internet connection before the feed was complete and the interface showed what I expected to see.

Thank you both. :slight_smile:

Now I’ll have a play with it and create a few scans.


Vulnerability reports only showing OIDs - command line to show database update status?