Setting up greenbone on a remote server (+ some errors during conifg)

Hi community!
Lastly I’ve configured Greenbone 22.4 on Ubuntu 20.04. My Ubuntu does not have GUI, since I wanted to connect to it remotely (on a local network). Currently Greenbone is running on the defaults - 127.0.0.1:9392.
My first question is: how to change that to the external address?

The second issue I’ve encountered is the following error showing up after “sudo gsad” command. Error:“Oops, secure memory pool already initialized”. What does it mean?

The last case: I don’t know how to restart greenbone services, or how to start it or stop. Do I have to do it seperately for all greenbone components? I’ve found no instruction for that on the official guide to install from source: https://greenbone.github.io/docs/latest/22.4/source-build/index.html

Thanks in advance for all help and feedback!

Hi,

the source build docs are using systemd service files (https://greenbone.github.io/docs/latest/22.4/source-build/index.html#starting-services-with-systemd) to manage the startup, stopping, etc. pp. That’s standard on most Linux distributions nowadays. You can look the details up with your preferred web search engine.

To change the web server to listen on an external address you need to adjust the gsad.service file and change the line
ExecStart=/usr/local/sbin/gsad --listen=127.0.0.1 --port=9392 --http-only. Replace 127.0.0.1 with whatever your host is available on. Afterwards you need to restart the gsad service.

The Oops, secure memory pool already initialized can safely be ignored.

2 Likes

Okay, thanks a lot!
Now I have another problem with setting up gvmd:
image
and “journalctl -xe” gives following output:


Any thoughts?

So I can say that it is related to the Notus Scanner, and it seems that the folder /var/lib/notus/products/ is not existing or a file?

Well, exactly - /var/lib/notus is empty directory. I don’t know why it is like that.

Have you already run greenbone-feed-sync?

yes, but I can rerun it (in progress right now)

1 Like


Now it looks like that.

Well, something is wrong. I can try to do the installation once more (kill the current machine and start over) but maybe there would be some better solution? If you have some ideas it would be great:)

looks like a permission problem for the process ID file …

1 Like

I’m running it as a sudo, how could it be a problem here :thinking:

Alright, I don’t know if reinstalling it on Ubuntu 22.04 (instead of 20.04), but I would try it out I think