Socket.timeout: timed out


#1

Hi there,

Trying to get a large csv report via gvm-cli fails with socket timeout error. My command is as follow:

gvm-cli socket --sockpath /var/run/openvasmd.sock --gmp-username admin --gmp-password pass -X ‘<get_reports report_id=“c7c183b1-117b-4582-a84a-f69e991a55dc” format_id=“c1645568-627a-11e3-a660-406186ea4fc5” filter=“apply_overrides=1 overrides=1 levels=hml” ignore_pagination=“1”/>’ report.xml

This fails with the following error:
Traceback (most recent call last):
File “/usr/local/bin/gvm-cli”, line 11, in
load_entry_point(‘gvm-tools==1.4.1’, ‘console_scripts’, ‘gvm-cli’)()
File “/usr/local/lib/python3.6/dist-packages/gmp/clients/gvm_cli.py”, line 213, in main
result = gvm.read()
File “/usr/local/lib/python3.6/dist-packages/gmp/gvm_connection.py”, line 103, in read
response = self.readAll()
File “/usr/local/lib/python3.6/dist-packages/gmp/gvm_connection.py”, line 967, in readAll
data = self.sock.recv(BUF_SIZE)
socket.timeout: timed out

I had the same issue with openvas-8/omp. Note that downloading the report in via GSA works without problems.

Any idea ?

Thanks


#2

Getting the report may take a while. It’s the heaviest and most difficult request for the backend. Therefore you may have to adjust the timeout settings by using the –timeout argument switch. If I remember correctly the default timeout is 60 seconds currently.


PDF reports size is limited to 1000 results
#3

That was it ! Raising the timeout to 600 did the trick.

Thanks for all your help !!