You should start the redis-server or configure it to listen on socket

redis

#1

I try to install openvas in Windows Subsystem Linux(Win 10) I got below error. Redise
redis-server is not running or not listening on socket: /var/run/redis-openvas/redis-server.sock
FIX: You should start the redis-server or configure it to listen on socket: /var/run/redis-openvas/redis-server.sock

oopenvas-check-setup 2.3.7
Mode: desktop
Date: Wed, 31 Oct 2018 00:03:48 +0800

Checking for old OpenVAS Scanner <= 2.0 …
/usr/bin/openvas-check-setup: 183: /usr/bin/openvas-check-setup: openvasd: not found

Checking presence of OpenVAS Scanner …
OpenVAS Scanner 5.1.3
Most new code since 2005: © 2016 Greenbone Networks GmbH
Nessus origin: © 2004 Renaud Deraison deraison@nessus.org
License GPLv2: GNU GPL version 2
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Checking OpenVAS Scanner version …

    OK: OpenVAS Scanner is present in version 5.1.3.

plugins_folder = /var/lib/openvas/plugins
cache_folder = /var/cache/openvas
include_folders = /var/lib/openvas/plugins
max_hosts = 30
max_checks = 10
be_nice = no
logfile = /var/log/openvas/openvassd.messages
log_whole_attack = no
log_plugins_name_at_load = no
dumpfile = /var/log/openvas/openvassd.dump
cgi_path = /cgi-bin:/scripts
optimize_test = yes
checks_read_timeout = 5
network_scan = no
non_simult_ports = 139, 445
plugins_timeout = 320
scanner_plugins_timeout = 36000
safe_checks = yes
auto_enable_dependencies = yes
use_mac_addr = no
nasl_no_signature_check = yes
drop_privileges = no
unscanned_closed = yes
unscanned_closed_udp = yes
vhosts =
vhosts_ip =
report_host_details = yes
kb_location = /var/run/redis-openvas/redis–server.sock
timeout_retry = 3
time_between_request = 0
config_file = /etc/openvas/openvassd.conf
Checking presence of redis …
OK: redis-server is present in version v=5.0.0.

Checking if redis-server is configured properly to run with openVAS …
OK: scanner (kb_location setting) is configured properly using the redis-server socket: /var/run/redis-openvas/redis–server.sock
Checking if redis-server is running …
ERROR: redis-server is not running or not listening on socket: /var/run/redis-openvas/redis-server.sock
FIX: You should start the redis-server or configure it to listen on socket: /var/run/redis-openvas/redis-server.sock


#2

Hi,

have you tried to follow the suggestions the openvas-check-setup script is giving you? As this is not directly related to OpenVAS / GVM please try to do some research on your own by having a look at e.g. the redis documentation concerning the correct configuration like https://redis.io/topics/config

If you’re struggling with the linux knowledge on this topic you could also try the GCE appliance which is configured and working out of the box within e.g. VirtualBox:


#3

This guy had a nice write up. It’s pretty simple and worked for me. You need to search google with the term " OpenVAS install error in Kali Linux". A link will be near the top with that title. For some reason the link is 404, but if you check the cached version it should pop up.

For me, it was as easy as uncommenting the two lines in the /etc/redis/redis.conf file for:

unixsocket /var/run/redis/redis.sock
unixsocketperm 700

Once I did that and restarted the Openvas services I had to do an update to the greenbone stuff (greenbone-scrapdata-sync).

Keep asking questions, keep looking.