Kali openvas 9 GSA

I install openvas 9 on kali. I alreadys install openvas9 and use url https://127.0.0.1:9392. But i can’t use my computer’s ip to open this management web.
I try to modify /lib/systemd/system/greenbone-security-assistant.service " --listen=127.0.0.1" to " --listen=0.0.0.0".
It still open management web https://ip:9392
How do I do? Thanks very much!

Please look for the correct area, Kali is not GOS.So i moved the topic.

I suggest you get back to the Kali Forum this uncoordinated integration is not supported here.

vi /etc/default/greenbone-security-assistant
GSA_ADDRESS=0.0.0.0

and

vi /lib/systemd/system/greenbone-security-assistant.service
-listen=0.0.0.0

systemctl daemon-reload

I also modify /etc/default/greenbone-security-assistant
GSA_ADDRESS=0.0.0.0
It still not work.

Wish I had found this earlier. This is exactly what I required to get it running.

For /etc/default/greenbone-security-assistant
GSA_ADDRESS=0.0.0.0

I set the IP to my server’s IP. Save and then do the following
systemctl daemon-reload followed by the services
service openvas-scanner restart
service openvas-manager restart
service greenbone-security-assistant restart
openvas-start

/lib/systemd/system/greenbone-security-assistant.service, set --listen and --mlisten to 0.0.0.0 and add --allow-header-host yourserver.yourcompany.com

setting the host as the FQDN and save. Run the following:
systemctl daemon-reload
systemctl greenbone-security-assistant
openvas-start

This worked for me. It’s been 10 years since I really used any Unix and I’m very rusty. Happy I got this going. Hopefully it helps. I also setup the A record, which was something I initially forgot.

I am using 5.2.0-kali2-amd64.