Fresh Install on Kali Linux Fails (User / Postgresql issue)

Hey all,

Completely new to Greenbone but having some issues installing on Kali Linux. Reading the other threads, it sounds like it might be a Kali problem not a Greenbone one, but wondering if anyone can help.

I have just installed Kali Linux on Parallels from fresh, and am now trying to install GVM.

I upgrade my postgresql version from 13 to 14, and can see a database is created:

gvmd | _gvm | UTF8 | en_US.UTF-8 | en_US.UTF-8 |

However, when I run gvm-check-setup I get the following fix:

       FIX: create a user by running 'sudo runuser -u _gvm -- gvmd --create-user=<name> --password=<password>'

As with other users, when I run this command nothing happens, but the database is there. If I go back and try and run gvm-setup, here’s the output:

i] User _gvm already exists in PostgreSQL
[i] Database gvmd already exists in PostgreSQL
[i] Role DBA already exists in PostgreSQL

[*] Applying permissions
NOTICE:  role "_gvm" is already a member of role "dba"
GRANT ROLE
[i] Extension uuid-ossp already exists for gvmd database
[i] Extension pgcrypto already exists for gvmd database
[>] Migrating database

(gvmd:82130): md manage-WARNING **: 23:45:00.698: Failed to open lock file '/run/gvm/gvm-create-functions': Permission denied
[>] Checking for GVM admin user
[*] Creating user admin for gvm
[*] Please note the generated admin password
[*] 
ERROR:  relation "settings" does not exist
LINE 1: SELECT value FROM settings WHERE uuid = '78eceaec-3385-11ea-...

Any ideas on how to resolve this? I have updated my postgresql version to the following:

psql (PostgreSQL) 14.0 (Debian 14.0-1)

GVM versions

gsad:
Greenbone Security Assistant 21.4.3

gvmd:
Greenbone Vulnerability Manager 21.4.4
Manager DB revision 242
Copyright (C) 2009-2021 Greenbone Networks GmbH
License: AGPL-3.0-or-later
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Environment

**Operating system: Kali Linux

I have the same issue, not mit Permission denied but instead with following:

(gvmd:3552): md manage-WARNING **: 11:36:11.656: Failed to open lock file ‘/run/gvm/gvm-create-functions’: No such file or directory
[>] Checking for GVM admin user
[] Creating user admin for gvm
[
] Please note the generated admin password
[]
ERROR: relation “settings” does not exist
LINE 1: SELECT value FROM settings WHERE uuid = '78eceaec-3385-11ea-…
^
[
] Define Feed Import Owner

(gvmd:3568): md main-CRITICAL **: 11:36:11.737: gvmd: g_option_context_parse: Missing argument for --value
[>] Updating GVM feeds
[*] Updating NVT (Network Vulnerability Tests feed from Greenbone Security Feed/Community Feed)
^C[>] Updating Vulnerability Tests info into Redis store from VT files

At the end the gmv-check-setup-script tell me that everything is fine, only the last point doenst work: To create a account. I search like hell via google to solve this problem without success. To reset the admin-acc doesnt work.

The PostgreSQL issue looks also quite similar to all recent reports from Kali users:

1 Like

I just went through the installation again using the current apt repository configuration files. I still received the same postgresql 14 error that I’ve been seeing for the last month. I performed the following set of commands and was able to get a complete install that generates a password for the admin account.

sudo apt update
sudo apt upgrade
#this will get the system updated with Postgresql 14 however there will also be the 13 version left so it needs to be removed and then modified to use port 5432
sudo pg_dropcluster --stop 13 main
sudo pg_ctlcluster 14 main stop
sudo pg_conftool show all
sudo pg_conftool 14 main set port 5432
sudo pg_ctlcluster 14 main start
sudo pg_lsclusters #just checking to see the 14 cluster is running on port 5432
sudo gvm-setup

All went well from there on…

2 Likes