How do I successfully add permissions for another user for the openvas 10 UI?

I am following the document in the manual for granting read permissions for the reports to another user to view.

got to Administrator > Roles
name field: GrantReadPriv
New Permission field: get_reports

click create permissions

I get this error: Given subject_type was invalid

no matter how I configure this I get the same error.

Using openvas 10 on fedora 30
I was am currently running a full, deep and ultimate scan at the time. If that was the issue I will report back.

Hi LaYne,

could you be a little more precise about what you have tried? Are you on the Roles page or actually on Permissions? There seems to be something wrong here.

If you grant someone the permission to get_reports, they will have the “general command permission” to get reports but that does NOT automatically grant read permissions to reports of another user (I guess that is what you are trying to accomplish?).
You could create a “Group” which includes the original user whose reports you want to share and put the other user, who should receive the read permissions, into that group as well. Make it a so called ‘Special Group’ and all users of this group share complete read and write permissions across all resources (even beyond reports). Keep in mind though, that this might cause some security risks, of course.
For a specific report you should be able to create a new “get_reports” permission in Administration > Permissions with the UUID of the report that you want to share entered in “Resource ID”.

1 Like

Yes it was on the roles section under administration. I didn’t edit any settings on the permissions page.

Well, I believe I accomplished what I set out to do just by assigning roles to the user. But I am trying your suggestion with adding the resource ID. I would rather be able to chose what reports any user is allowed to view. Right now they can see all reports.

Thank you
I’ll report back.