How to edit config file in order to allow for a /16 subnet target?

How to adjust config file (openvassd.conf?) to allow for a 16-bit subnet mask network?
Thanks.

The limitation for maximum IPs per target is implemented in the management service, not the scanner.
The limits are intentional to keep reports in a manageable size.

Please also have a look at this topic:

2 Likes

Oh okay, so where do I change it in the Management Service?
The report won’t be unmanageable since there are only around 500 live IPs, they are just scattered throughout many different /24 subnets. If I had to manually add individual /24 networks, I’d have to add over 100 target networks! So, like I said the report won’t be unmanageable, but adding that many targets surely would. Is the Management Service accessible from the web page? Thanks.

The management service is called gvmd in


and openvasmd in

The source can be found at

Sorry, I’m new here, but are you saying I need to download/install a separate product in order to add a /16 network?

Looks like there is a misunderstanding here:

What @bricks wanted to point out is that the limit is not enforced by the scanner (openvassd.conf) as you had initially assumed but within the named/linked manager daemon (openvasmd/gvmd). This was just an informative post to point out where the current upper limit is coming from / enforced.

Okay, it seems like we are narrowing in on the solution. How do I adjust the upper limit within the manager daemon (openvasmd/gvmd)? Thanks.

I guess it can be adjusted by the --max-ips-per-target option but I am not sure if there is another hard limit.

1 Like

I tried out openvasmd --max-ips-per-target 0 but nothing changed can you @bricks help me to figure this out ? Many Thanks!

gvmd has a global hard limit of 70000 hosts per target.

Yeah but a /16 subnet only got 65536 -2 available hosts …

@all Please keep in mind that you shouldn’t run such commands like openvasmd on the command line when running the GCE as this environment is quite different from a GSE installation. You might break permissions and similar when doing so.

Unfortunately i havn’t found any documentation how to set this limit for GCE though.

Let me catch up with that topic:
Is there any config file to adjust the behaviour of gvmd?
Something in /etc/gvm/?