Installation error gvmd: symbol lookup error: gvmd: undefined symbol: gvm_file_is_executable

Use this category only if you have build GVM from sources or if you use packages provided by a 3rdparty repository.

Please read About the Greenbone Source Edition (GSE) and About GVM Architecture before posting.

When posting you should provide information about your environment using the following template:

GVM versions

gsad: (‘gsad --version’) --> Oops, secure memory pool already initialized
Greenbone Security Assistant 20.08.1~git

gvmd: (‘gvmd --version’) --> gvmd: symbol lookup error: gvmd: undefined symbol: gvm_file_is_executable

openvas-scanner: (‘openvas --version’, in older GVM versions < 11: ‘openvassd --version’) --> OpenVAS 20.8.1

gvm-libs: --> gvm-libs 20.8.0~git-7a9a5b4-gvm-libs-20.08

Environment

Operating system:
Kernel: (‘uname -a’) --> Linux 5.10.0-kali3-amd64 #1 SMP Debian 5.10.13-1kali1 (2021-02-08) x86_64 GNU/Linux

Installation method / source: --> aptitude install gvm

Hello,
When execute gvm-setup finish with this error and don’t start the service.

[*] Checking Default scanner
gvmd: symbol lookup error: gvmd: undefined symbol: gvm_file_is_executable
[*] Modifying Default Scanner
gvmd: symbol lookup error: gvmd: undefined symbol: gvm_file_is_executable

Anyone can help me ?

A greeting and thanks

This looks to me like a problem in the Kali packages (these are not provided / maintained by Greenbone):

This is an older version of gvm-libs 20.8.0 (not providing the required gvm_file_is_executable function mentioned yet) which doesn’t match the recent 20.8.1 releases required by the following components already updated to 20.8.1:

Please report a new issue to the Kali package maintainer here: https://bugs.kali.org/my_view_page.php

1 Like

Hello,

I upgrade the library but the gvm don’t start I run the setup again and when finished I have this error

[*] Checking Default scanner
gvmd: symbol lookup error: gvmd: undefined symbol: gvm_file_is_executable
[*] Modifying Default Scanner
gvmd: symbol lookup error: gvmd: undefined symbol: gvm_file_is_executable

[+] Done


A greeting and thanks

You are still having an issue with the provided packages. You gvm-libs version doesn’t fit to the version gvmd is expecting. Please contact the maintainers of the packages (Greenbone isn’t involved in packaging at all) to fix this issue.

1 Like