My openvas-scanner wont run

Use this category only if you have build GSE or components thereof from sources .

Please read About the Greenbone Source Edition (GSE) and About GVM Architecture before posting.

When posting you should provide information about your environment using the following template:

GVM versions

**gsa: Greenbone Security Assistant 7.0.3
**gvm: N/A
**openvas-scanner: OpenVAS Scanner 5.1.3
gvm-libs:

Environment

**Operating system: Ubuntu 16.04.6 LTS
**Kernel: Linux infra-sec-001 4.4.0-154-generic #181-Ubuntu
**Installation method / source: Repository

It was working just fine and it has no update pending and now I cant start openvas-scanner because always got same here, you can see it here


● openvas-scanner.service - LSB: remote network security auditor - scanner
Loaded: loaded (/etc/init.d/openvas-scanner; bad; vendor preset: enabled)
Active: failed (Result: timeout) since Thu 2019-07-18 15:05:34 -05; 16min ag
Docs: man:systemd-sysv-generator(8)
Process: 32282 ExecStart=/etc/init.d/openvas-scanner start (code=killed, sign
Tasks: 14
Memory: 21.0M
CPU: 151ms
CGroup: /system.slice/openvas-scanner.service
├─ 1256 /usr/sbin/openvassd
├─ 2182 /usr/sbin/openvassd
├─ 2531 /usr/sbin/openvassd
├─ 3530 /usr/sbin/openvassd
├─ 8664 /usr/sbin/openvassd
├─ 8819 /usr/sbin/openvassd
├─13118 /usr/sbin/openvassd
├─13770 /usr/sbin/openvassd
├─17795 /usr/sbin/openvassd
├─18021 /usr/sbin/openvassd
├─19986 /usr/sbin/openvassd
├─20066 /usr/sbin/openvassd
lines 1-21…skipping…
● openvas-scanner.service - LSB: remote network security auditor - scanner
Loaded: loaded (/etc/init.d/openvas-scanner; bad; vendor preset: enabled)
Active: failed (Result: timeout) since Thu 2019-07-18 15:05:34 -05; 16min ago
Docs: man:systemd-sysv-generator(8)
Process: 32282 ExecStart=/etc/init.d/openvas-scanner start (code=killed, signal=TERM)
Tasks: 14
Memory: 21.0M
CPU: 151ms
CGroup: /system.slice/openvas-scanner.service
├─ 1256 /usr/sbin/openvassd
├─ 2182 /usr/sbin/openvassd
├─ 2531 /usr/sbin/openvassd
├─ 3530 /usr/sbin/openvassd
├─ 8664 /usr/sbin/openvassd
├─ 8819 /usr/sbin/openvassd
├─13118 /usr/sbin/openvassd
├─13770 /usr/sbin/openvassd
├─17795 /usr/sbin/openvassd
├─18021 /usr/sbin/openvassd
├─19986 /usr/sbin/openvassd
├─20066 /usr/sbin/openvassd
├─29861 /usr/sbin/openvassd
└─32288 /usr/sbin/openvassd

Jul 18 15:00:34 infra-sec-001 systemd[1]: Starting LSB: remote network security auditor - scanner…
Jul 18 15:05:34 infra-sec-001 systemd[1]: openvas-scanner.service: Start operation timed out. Terminating.
Jul 18 15:05:34 infra-sec-001 systemd[1]: Failed to start LSB: remote network security auditor - scanner.
Jul 18 15:05:34 infra-sec-001 systemd[1]: openvas-scanner.service: Unit entered failed state.
Jul 18 15:05:34 infra-sec-001 systemd[1]: openvas-scanner.service: Failed with result ‘timeout’.

Please your support with this

I would try to start it without SystemD as beginning :wink: And don´t send him into the background.

Closing as a duplicate of various existing threads (linked below) which can be found with simple search terms like e.g.:

https://community.greenbone.net/search?q=%22Start%20operation%20timed%20out%22
https://community.greenbone.net/search?q=%22openvas-scanner.service%22%20%22timeout%22

Please follow-up in the existing thread if you have further questions around this topic.