(R)Syslog gets disabled during 4.2.22 to 4.3.2 upgrade

gos-42
gos-43

#1

To whom it concerns.

After upgrading our GSM100’s from 4.2.22 to 4.3.2 the (remote) syslog configuration did not work anymore, nothing made it to the ®syslog server. It turned out, the upgrade did set this to “disabled”:

                      +----------------------------Remote Logging------------------------------+
                      ¦ This is the configuration menu for Remote Logging.                     ¦
                      ¦ +--------------------------------------------------------------------+ ¦
                      ¦ ¦   Security Syslog  [disabled]                                      ¦ ¦
                      ¦ ¦   Security Remote  Set the remote security Syslog-Server URL       ¦ ¦
                      ¦ ¦   Full Syslog      [disabled]                                      ¦ ¦
                      ¦ ¦   Full Remote      Set the remote full Syslog-Server URL           ¦ ¦
                      ¦ ¦   Certificates     Configure the certificate for remote logging.   ¦ ¦
                      ¦ +--------------------------------------------------------------------+ ¦
                      ¦                                                                        ¦
                      ¦                                                                        ¦
                      +------------------------------------------------------------------------¦
                      ¦                     <  OK  >           < Back >                        ¦
                      +------------------------------------------------------------------------+

On 4.2.x there were no explicit options however, to enable/disable this. It was done by simply datafilling (or not) the URL’s.

Enabling syslog, fixed that too:

                      +----------------------------Remote Logging------------------------------+
                      ¦ This is the configuration menu for Remote Logging.                     ¦
                      ¦ +--------------------------------------------------------------------+ ¦
                      ¦ ¦   Security Syslog  [disabled]                                      ¦ ¦
                      ¦ ¦   Security Remote  Set the remote security Syslog-Server URL       ¦ ¦
                      ¦ ¦   Full Syslog      [enabled]                                       ¦ ¦
                      ¦ ¦   Full Remote      Set the remote full Syslog-Server URL           ¦ ¦
                      ¦ ¦   Certificates     Configure the certificate for remote logging.   ¦ ¦
                      ¦ ¦   Save             Save the pending modifications                  ¦ ¦
                      ¦ +--------------------------------------------------------------------+ ¦
                      ¦                                                                        ¦
                      ¦                                                                        ¦
                      +------------------------------------------------------------------------¦
                      ¦                     <  OK  >           < Back >                        ¦
                      +------------------------------------------------------------------------+

The actual target URL “tcp:…” configured survived the upgrade however. Though I recommend to back them up / note them down prior the upgrade.