Scans finish instantly without returning any results

gvm-10

#1

I suspect I am seeing the same issue, but still no solution. I’m running the mrazavi PPA on Ubuntu 18.04 (gvmd 8.0.0 sqlite3, openvassd 6.0.0). When I turn on log_whole_attack, I see ping_host.nasl start, but not finish, then I get the “Test complete” message. Here are the relevant lines from openvassd.conf (excluding the “not launching” messages):

sd main:MESSAGE:2019-05-15 18h21.52 utc:3765: Starts a new scan. Target(s) : 172.30.1.9, with max_hosts = 2 and max_checks = 2
sd main:MESSAGE:2019-05-15 18h21.52 utc:4739: Testing 172.30.1.9 [4739]
sd main:MESSAGE:2019-05-15 18h21.52 utc:4739: Launching toolcheck.nasl (1.3.6.1.4.1.25623.1.0.810000) against 172.30.1.9 [4740]
sd main:MESSAGE:2019-05-15 18h21.52 utc:4739: toolcheck.nasl (1.3.6.1.4.1.25623.1.0.810000) [4740] finished its job in 0.025 seconds
sd main:MESSAGE:2019-05-15 18h21.52 utc:4739: Launching nmap_nse_net.nasl (1.3.6.1.4.1.25623.1.0.108083) against 172.30.1.9 [4745]
sd main:MESSAGE:2019-05-15 18h21.52 utc:4739: nmap_nse_net.nasl (1.3.6.1.4.1.25623.1.0.108083) [4745] finished its job in 0.003 seconds
sd main:MESSAGE:2019-05-15 18h21.52 utc:4739: Launching ping_host.nasl (1.3.6.1.4.1.25623.1.0.100315) against 172.30.1.9 [4746]
sd main:MESSAGE:2019-05-15 18h21.52 utc:3765: Test complete
sd main:MESSAGE:2019-05-15 18h21.52 utc:3765: Total time to scan all hosts : 5 seconds

The strange thing is that if I create several Ubuntu 18.04 VMs and apt install gvm on all of them, scans will work on one or two.

If I should have started my own thread, I apologize and invite your reproof.

Karl


Greenbone 10 nvt 0/0
#2

Hi @Karl,

Your issue seems to be different, and maybe related to plugins timeout.

Could you please check the values of plugins_timeout and scanner_plugins_timeout preferences in your scan config & openvassd.conf ? These should be positive numbers.

A fix to catch this error should arrive in the next stable version.


#3

I discovered the very same error as @Karl.

Happy to say that with PR https://github.com/greenbone/openvas-scanner/pull/330 everything works fine again :+1:


#4

Note that the scan config that I received to reproduce this issue, had an erroneous “scanner_plugins_timeout” scan config preference value (“SCANNER_NVT_TIMEOUT” string instead of an actual integer value)

Just for reference, in case someone else has a similar issue.


#5

I also had scanner_plugins_timeout = SCANNER_NVT_TIMEOUT, so I changed it to 36000, but the behavior remains the same. I have plugins_timeout = 320.


#6

Doing a git pull fixed the problem. Something must have changed in the past few days, because the latest code didn’t fix this issue last Friday.


#7

See:

The PR was merged today so this explains why a git pull from today fixed your problem. :slightly_smiling_face: