Start of gvmd failed

Hello together,

I hope somebody can help me.
I work with Greenbone Vulnerability Manager 9.0.0 on CentOs 8.
It worked fine, till last week. I dont know what happened, but gvmd crashed and it is not possible to start ist again.
I found in gvmd.log following error, and I dont knoe what does it mean and how I can fix it.

md manage:WARNING:2020-09-07 10h14.32 utc:2825: sql_open: PQconnectStart to ‘gvmd’ failed: could not connect to server: No such file or directory
** Is the server running locally and accepting**
** connections on Unix domain socket “/var/run/postgresql/.s.PGSQL.5432”?**

md manage:WARNING:2020-09-07 10h28.19 utc:4586: sql_exec_internal: PQexec failed: FEHLER: konnte Bibliothek »/usr/lib64/libgvm-pg-server.so« nicht laden: /lib64/libgvm_util.so.11: undefined symbol: gnutls_x509_privkey_import

I have looked for this error in google, but just found this error in dependence with compilation of gvmd.
it worked already for me and I already scanned some targets with it.
Does anybody have idea what can I do?
I have searched for /var/run/postgresql/.s.PGSQL.5432 and I found one.
in this directory I can see also .s.PGSQL.5432.lock

thanks a lot.

Looks like you or your system has uninstalled some mandatory libraries (namely gnutls) which is required by the libgvm-pg-server.so binary.

thank you for your answer. I asked my provider for it,
they found out that following libs are installed:
[root]# rpm -qa |grep gnutls
gnutls-dane-3.3.29-9.el7_6.x86_64
gnutls-3.3.29-9.el7_6.x86_64
gnutls-utils-3.3.29-9.el7_6.x86_64

do you know which libs are required?

You have to look with ldd what external libs are needed:
e.g.:
# ldd /usr/lib64/libgvm-pg-server.so
linux-vdso.so.1 (0x0000ffffb685b000)
libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x0000ffffb66c9000)
libgvm_base.so.11 => /usr/lib64/libgvm_base.so.11 (0x0000ffffb66a7000)
libgvm_util.so.11 => /usr/lib64/libgvm_util.so.11 (0x0000ffffb667d000)
libical.so.3 => /usr/lib64/libical.so.3 (0x0000ffffb65f7000)
libc.so.6 => /lib64/libc.so.6 (0x0000ffffb6494000)
/lib64/ld-linux-aarch64.so.1 (0x0000ffffb682d000)
libpcre.so.1 => /lib64/libpcre.so.1 (0x0000ffffb6447000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x0000ffffb6418000)
[…]

or recompile your complete stack against the new dependencies.

I’m not familiar with the RPM world but on Debian the lib is called “libgnutls” which isn’t included in your output.